API Downtime
Incident Report for acrd.app
Resolved
Recaptcha v3 has been added to the register page to help prevent similar activity.
Posted Jun 05, 2023 - 11:04 BST
Update
The API was abused and hundreds of spam users were created.
You can now only make 1 account every 10 minutes, instead of 10 every 10 minutes.
Also other rate limits are now more strict.
All recent spam accounts have been deleted.
Posted Jun 04, 2023 - 18:55 BST
Monitoring
Seems to be MongoDB caused (again).
Will restart the server more frequently, and setup an accord downtime alert pipeline.
The biggest problem is that I just found out it 12 hours after it happened, not the problem itself.
Posted Jun 04, 2023 - 18:41 BST
This incident affected: API.